LiteCommerce:Installation and configuration FAQ

From X-Cart 4 Classic
Jump to: navigation, search
Warning.png This article refers to LiteCommerce 2.x only. For user manual to LiteCommerce 3.x, please visit this website.


LC version2.xonly

What are the server requirements for LiteCommerce ?

LiteCommerce is tested on FreeBSD, Linux, Win2000/NT and MacOS X servers running Apache and IIS web servers. For more details please see LiteCommerce:System requirements.

Do I need to have root access to server in order to install LiteCommerce ?

Root access is not required.

Does LiteCommerce support PHP5 ?

LiteCommerce v2.2 and higher can work on PHP5-powered servers. Older LiteCommerce versions do not support PHP5.

Can I integrate my existing database with LiteCommerce ?

You can modify the source code of LiteCommerce to integrate it with any database. However, LiteCommerce is a very complex software which consists of more than 280 PHP files. We recommend you converting your current database to LiteCommerce format. This can be done by using the import feature of LiteCommerce.

I'm not sure if LiteCommerce will work on my host because of ionCube source code protection technology. How can check it?

You can download free ionCube loaders for your operation system and PHP version and use Real Time Loader Tester or Loader Install Assistant scripts included in the loaders package to test if ionCube can work at your system. However if you failed that doesn't mean that it is impossible to run LiteCommerce at your host, LiteCommerce has a specially designed loader initialization code which is optimized to run with LiteCommerce software.

Is it possible to make LiteCommerce forward users to secure (HTTPS/SSL) URL when they come to the checkout page ?

Yes, this can be easily done with LiteCommerce.

I'm getting a 500 Internal Server Error during installation, what should I do?

Internal server errors can be usually caused by one of the issues discussed here.

Is it possible to change the currency/weight symbol ?

Yes, you can define currency/weight symbols using the Admin interface.

Does LiteCommerce support configurable language files ?

The basic version of LiteCommerce can be translated into any language however can not support multiple languages. LiteCommerce can support only one language in default functionality. If you need a multi-language store please use X-Cart.

Can I use Microsoft FrontPage / Macromedia Dreamweaver to edit my LiteCommerce pages ?

Yes, the template system of LiteCommerce products is specially produced to make editing its pages with FrontPage, Dreamweaver and other WYSIWYG web editors easy.

Is it possible to upgrade the 30day free trial store to a production version?

Unfortunately, the trial version is not upgradeable. However, there is a workaround.

If the trial cart does not expire yet, do not remove it. After you do a fresh LiteCommerce installation on your server, you will be able to export the products from the trial version and import them into the new LiteCommerce installation. Then copy "skins/default" and "skins_original/default" folders from your trial installation into the same folders of the new cart.

I'm having problems installing LiteCommerce add-ons.

Most likely one of the following directories don't have the writable permissions:

  • classes/modules/
  • skins/admin/images/
  • skins/admin/en/modules/
  • skins/admin/en/images/modules/
  • skins/default/en/modules/
  • skins/default/en/images/modules/
  • skins/mail/en/modules/

You should check these directories. If some of them do not exist, you can create them manually via ftp or Cpanel. Then set writable access permissions on all of them. After you set the writable permissions, try to install the modules once again. Also, please refer to this article.

How to create a new admin account?

1) Run the installation script, i.e. http://www.your_site.com/your_LiteCommerce folder/install.php

2) Type in the 'auth code'. It can be found in the 'litecommerce_root_folder/etc/config.php' file, in the following lines: [installer_details] auth_code = "[your_auth_code]"

3) Select "Configure the default administrator account" option and tick 'I accept the License Agreement' box, then click on the 'Next' button;

4) on the new page, set the new admin's e-mail address and password and follow the registration procedure.

Installation script asks me to set permissions for some files and directories. What are permissions?

Please refer to X-Cart installation FAQ.

How to remove "Powered by LiteCommerce: ecommerce software"?

"Powered by LiteCommerce: ecommerce software" text is edited in the skins/default/en/powered.tpl template. Please be noted that changing the name of LiteCommerce in the logo is not permitted by the License Agreement as it would be considered as rebranding. If you do not want this logo to be displayed you can comment out or remove the line in the powered.tpl file.

How do I customize the look of my store?

Please refer to LiteCommerce:Customizing storefront page.

How to install modules?

1. Download a necessary module from the file area of your Qualiteam account to your local PC.

2. In the LiteCommerce administration back-end, under "Settings" menu go to "Modules" page;

3. Scroll down to "Install new module" section. To install the new module, click on the 'Browse' button and load the corresponding file from your local hard disk. You can load only a .tar file provided by LiteCommerce.

4. Click on the "Install" button.

Notes:

Before starting installation of a new commercial module, you should upgrade your cart license to the new version which includes this new module.

The new "License Certificate" is in "My Licenses" section of your X-Cart Account:

  • Click the "Certificate" link opposite the corresponding license. The "License certificate" window will appear.
  • Copy the whole license text and paste into the "License" window under the "License" section in the cart admin area. The license text has two parts (customer information and license key). You should copy the full text of the license (both parts).

During the installation the old module's templates will be overwritten by the new ones. If you had any customizations done to the module, you should re-apply them on the new module templates.

We recommend you to backup your cart files and the store database before the installation. In this case you'll easily find the necessary mods and update the new templates.

How to set up HTTPS?

First of all, make sure that you have an SSL certificate installed for your site. You can ask your hosting administrator to check it and help with the installation of the certificate if needed. Then try to open your home page via HTTP and HTTPS protocols. If you are able to view both - your HTTPS server name is correct.

To set HTTPS access to your cart, follow the instruction below:

1) Type correct information on http and https hosts in the file 'litecommerce_root_folder>/etc/config.php':

[host_details]
http_host = "your_domain.com"
https_host = "your_security_domain.com"
web_dir = "/litecommerce_folder"

Fill in the "https_host =" line with your HTTPS URL (without the "https://" prefix).

2) Test it by typing in your browser the following URL: https://https_host_from_config.php/[Litecommerce_folder]

3) In LiteCommerce administration back-end, enter "General Settings" section and enable necessary features in "Security" tab:

  • "Turn on HTTPS for customer's zone"
  • "HTTPS client" field should remain "Autodetection".

Click on the "Submit" button to apply changes.

4) Check if HTTPS works fine for the customer zone. Then you can repeat the step #3 to set HTTPS for the admin zone.